Skip to main content
Not seeing an article?
Phoenix Ortho

XMR Viewer Manual

Overview

This will explain how to manipulate images in the viewer, from laying out images , using the tools, sorting images , making measurements, adding test annotations, undo/redo, and keyboard shortcuts.

Goal

After completing this how-to you will understand the common everyday tabs that are explained in "XMR for the Providers Staff" and the in depth advanced viewing tools explained in this article.

Using Tools

Most of the basic image viewing tools are fairly intuitive to use. There are 2 types of tools:

Regular Tools

Regular tools are those tools that, when pressed, immediately operate on the selected displaid image. Invert is an examples of that kind of tool. To use regular tools, simply:

1.  Highlight in the Viewer and the image you want to manipulate.

2.  Click on the desired toolbar button to apply the operation.

Mouse Tools

Mouse tools are tools whose functions are mapped to a particular mouse button. Window/Level, Zoom, Pan are examples of such tools. The button to which the function is assigned is indicated on the toolbar button. To use mouse tools simply:

Use your mouse and highlight the tab, example Pan in the above image is a left click of the mouse and the magnify is the right click of the mouse. If the Pan is highlighted, a left click on the mouse, will allow you to Pan on the image. A small hand will be on the image when the Pan tab is engaged.

Below is a brief description of Mouse tools: 

Tool

Mouse Button

Usage

Stack

Left

Hold mouse button down, drag vertically.

(Stacking is the process of paging through the images in a display set, colloquially known as a stack)

Window/Level

Right

Hold mouse button down, drag horizontally and vertically.

(Window/Level is a similar concept to adjusting "brightness and contrast".)

Zoom

Right

Hold mouse button down, drag vertically.

Pan

Left

Hold mouse button down, drag horizontally and vertically.

(Pan is dragging the image around in the tile)

Magnifying Glass

Left

Hold mouse button down, drag horizontally and vertically.

     

Reference

Lines

Right

Hold mouse button down, drag horizontally and vertically.

     

Ruler

Left

2 clicks define the ruler, one for each endpoint.  Note that there is no need to hold the mouse button down.

Elliptical ROI

Left

2 clicks define the corners of the ROI.  Note that there is no need to hold the mouse button down.

Rectangular ROI

Left

2 clicks define the corners of the ROI.  Note that there is no need to hold the mouse button down.

Polygonal ROI

Left

Repeated clicks draw the ROI.  To complete, bring mouse back to first point or simply double-click.  Note that there is no need to hold the mouse button down.

     

Protractor

Left

First and third click define end points, second click defines vertex.  Note that there is no need to hold mouse button down while drawing.

To use the above mouse tools make sure the tab is highlighted on the tool bar.

Shortcut for Mouse tools:

Tool

Shortcut

Stack

Mouse Wheel

Window/Level

Middle Mouse Button

Zoom

CTRL-Mouse Wheel

Pan

CTRL-Left Mouse Button

The above mouse tools can be used even when they are not highlighted in the toolbar.

Sorting Images

If you right click on the image as seen above you can choose the slice by location or number.

Or you can click on the  stack tabs, drop down arrow to search by time, number or location of slice. 

Measurements and Annotations

Measurement tools, such as the Ruler and Protractor, as well as the Elliptical, Rectangular and Polygonal ROIs, can be drawn on an image in the following way:

1.  On the toolbar, click on the measurement tool you wish to use.

2.  Click on the image where you want to begin. This will lay down the measurement's first anchor point.  Note that you can just click and release, you do not need to hold.

3.  Move the mouse to where you want the next anchor point to be located.  Click and release.

4.  If the measurement tool you're using only requires two anchor points (as in the case of the Ruler, as well as Elliptical and Rectangular ROIs), you're done. However, if the tool requires more anchor points (as in the case of the Protractor and Polygonal ROI), you need to repeat step 3 until the measurement is complete.

5.  In the case of the Polygonal ROI, there are additional things to note: 

  •   The ROI can be closed in one of two ways: by bringing the mouse back to the first point ( a circular "snap-to" region will appear to assist) or by simply double- clicking provided you have already deposited at least 2 points.
  • If you have already completed the ROI and wish to make a small adjustments, you can add and remove vertices ( anchor points) using the right click menu.  To add a new vertex, right click on the body of the ROI approximately where you would like the new vertex to be added and select Insert Vertex.  To remove vertex, simply right click the individual vertex and chose Delete Vertex.

6.  To resize a measurement, hover the mouse over one of its square control points and lick and drag as necessary.

7.  To move a measurement, hover the mouse over its body, then click and drag to the new location. Note that the callout can also be moved out of the way by dragging.

8.  To delete a measurement, right click on the measurement and select delete.

9.  To delete all annotations, including measurements and text right click on the item itself or on the image and select Delete all Annotations.

10.  To assign a name to a particular measurement, simply right click and choose Rename; a text edit box will appear.  Enter an appropriate name and press ENTER on the keyboard, or simply click away from the measurement with the mouse.  The text will appear in the measurements callout along with it's statistics/analysis.

 11.  To hide the statistics, leaving only the name if one has been entered, simply right lick on the measurement and uncheck Show Analysis.

Reference Lines

To view Reference lines on the image, click on Tools in the tool bar, drop down to Synchronization and over to Reference Lines. Click to display or remove. The number beside each Reference line corresponds to the image number of the intersecting image.

Cine Tool

The Cine tab will allow you to automatically stack thru images in the selected image box at a set rate. 

Toolbar Tabs Described

1. Undo: Takes away the last command in the command history. It will take you back to the last image you were viewing, or take away a measurement.

2. Redo:  After you Undo a command you can then Redo the command with the Redo tab.

3.  Click to display thumbnails: Will add thumbnails to your view.

4.  Layout Manger: Once you have opened your study, it allows you to easily change the display layout of the images.

5.  Show/Hide Overlays: Allow four Overlays to be individually toggled: Text layer, DICOM Overlays, Image Scale and Display Shutters.

6.  Stack: Paging through the images in a display set.

7.  Window Level: Adjusting the contrast and brightness of the image.

8.  Pan: Pans around the image by dragging the image.

9.  Zoom:  Adjusts the size of the image by dragging up and down.

10. Rectangle Zoom: Allows you to choose the size and part of the image to enlarge.

11. Ruler:  Allows you to make measurements on the images.

12.  Flip:  Image will Flip horizontal, vertical, clockwise and counterclockwise.

13.  Cine: Automatically stack through images.

14.  Multi Planar Reconstruction: Allows users to generate images from additional perspectives and builds a 3 dimensional volume from an entire stack of images. (unavailable at this time)

15.  Invert: Inverts the image from black and white, to white and black.

16.  Free Hand drawing:  Allows you to draw on the image. This will not save to the image. But allows you to free form annotate on the image to show the patient.

17.  Synchronized Stacking: Synchronized images that are in the same plane according to slice location. ( Example would be an Axial CT image that were acquired with different parameters, but you want to view them together.)

18.  Export Study:  Opens folders on your computer to be able to copy images to a disc.

19.  Stitching: Merging together 2 images for use in Scoliosis Films and Long Legs.

File, Edit, View and Tools

This is the Workflow row in the Viewer.

File

When you click on File, your options are to Close workspace- This feature is disabled, or Close, which will close the viewer.

Edit

The Edit tab will give you another way of using the Undo and Redo tab. If you Undo your last key stroke, then you want to put it back, click on Redo.

View

The View tab will give you another way to open up the Thumbnails. Click on this tab and the Thumbnails open in the viewer.

Tools

The Tools Tab will allow you to access the following:

Layout Manager, and all the Toolbar Tabs including Flip Vertical, Rotate Left, and Rotate Right. Click here for detailed description of these areas.

 

Synchronization Stacking, Link Studies and Reference Lines as described above in the Toolbar Tabs.

 

Measurement to include Ruler, Elliptical ROI, Rectangular ROI, Polygonal ROI, Cobb Angle and Protractor ( all described above in Measurements.)

Options

The Options tab is where the Provider will set up preferences for his/her workstation.

A number of user preferences can be changed from the Tools > Options dialog:

Date Format-  Sets the date format for display throughout the application.

Default Servers-Sets the default server(s) for publishing and automatically searching for related/prior studies.- NOT AVAILABLE 

Dicom Server-Configures the AE title and listening port for the DICOM service.   Phoenix Ortho Personnel Only

Diskspace Manager-  Sets thresholds for automatic diskspace management. Phoenix Ortho Personnel Only

Explorer Dicom- NOT AVAILABLE

External Applications- NOT AVAILABLE

Layout-Sets modality-based default image box and tile layouts. NOT AVAILABLE AT THIS TIME

Display Sets Layout- Sets options for splitting images in a single series into different display sets, such as mixed multi-frame or multi-echo series.

MPR- Configures advanced options for the MPR component. NOT AVAILABLE

Synchronization Tools- Set the tolerance for images to be considered parallel for reference lines and when performing synchronized stacking. NOT AVAILABLE

Toolbar- Configures whether or not the main toolbar should wrap around and the size of icons to display.  By default, the toolbar has large icons and has a spillover for more icons. You can choose the size of you Toolbar icons and mouse Bindings for Stack, Window Level, Pan and Zoom.

Window Configuration- Configures the opening of images in the same window as the Explorer, or a different one.  The latter is useful in the multi-monitor scenario, where it is preferable to have the Explorer window on one monitor, and the image window span the remaining monitors. NOT AVAILABLE

Window /Level- Modality based window & level presets. NOT AVAILABLE

 

 

 

 

 

 

 

 

 

 

This is what was achieved and what was omitted in this how-to.